【PAT甲级】1064 Complete Binary Search Tree (二叉搜索树与完全二叉树)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

 

 

分析:

首先要明白一点:已知一个序列,构建出来的搜索二叉树为什么不唯一,答案:因为无法确定哪个是根节点。

其次要知道二叉搜索树的一些性质:

  1. 二叉搜索树的先序遍历序列即为其构建的先后顺序。
  2. 二叉搜索树的中序遍历序列即为其所有结点的data域从小到大的排列。

二叉树的性质:

本题的二叉搜索树为完全二叉树,我们可以利用其是完全二叉树和结点总数固定的已知条件,确定其根节点(先排序,再计算),进而确定这个唯一的二叉搜索树。

 

柳神的优秀解法:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
vector<int> in, level;
void levelorder(int start, int end, int index) {
    if(start > end) return ;
    int n = end - start + 1;
    int l = log(n + 1) / log(2); // 得到二叉树的高度 
    int leave = n - (pow(2, l) - 1);// 最后一层的叶子节点数
    int root = start + (pow(2, l - 1) - 1) + min((int)pow(2, l - 1), leave);
	/* pow(2, l - 1) - 1是除了root结点所在层和最后一层外,
	左子树的结点个数,pow(2, l - 1) 是l+1层最多拥有的属于根结点左子树的结点个数,
	min(pow(2, l - 1), leave)是最后一个结点真正拥有的属于根结点左子树上的结点个数
	*/ 
    level[index] = in[root];
    levelorder(start, root - 1, 2 * index + 1);
    levelorder(root + 1, end, 2 * index + 2);
}

int main() {
    int n;
    scanf("%d", &n);
    in.resize(n);
    level.resize(n);
    for(int i = 0 ; i < n; i++)
        scanf("%d", &in[i]);
    sort(in.begin(), in.end());
    levelorder(0, n - 1, 0);
    printf("%d", level[0]);
    for(int i = 1; i < n; i++)
        printf(" %d", level[i]);
    return 0;
}

 

本菜鸡的一次错误尝试:

#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>

using namespace std;
struct node{
	int data;
	node *left,*right;
};
int n;

vector<int> in; 


void insert(node* &root,int data)
{
	if(root==NULL)
	{
		root=new node;
		root->data=data;
		root->left=root->right=NULL;
		return;
	}
	
	if(data < root->data) insert(root->left,data);
	if(data > root->data) insert(root->right,data);
}

int num=0;
void bfs(node* root)
{
	queue<node*> q;
	q.push(root);
	while(!q.empty())
	{
		node* top=q.front();
		q.pop();
		printf("%d",top->data);
		num++;
		if(num<n) printf(" ");
		if(top->left !=NULL) q.push(top->left);
		if(top->right!=NULL) q.push(top->right);
	}
}

int main()
{
	int temp;
	node* root=NULL;
	scanf("%d",&n);
	in.resize(n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&in[i]);
	}
	sort(in.begin(),in.end());
	for(int i=0;i<n;i++) printf(" %d",in[i]); 
	
    //定位根结点的索引
	if(n%2==0) temp=n/2;
	else temp=(n-1)/2;
	
	root=new node;
	root->data=in[temp];
	root->left=root->right=NULL;
	
	printf("temp:%d",temp);
	
	for(int i=0;i<n;i++)
	{
		if(i!=temp)
		insert(root,in[i]);
	}
	
	bfs(root);
	return 0;
}

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值