【PAT】1064. Complete Binary Search Tree (30)【完全二叉搜索树】

题目描述

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

翻译:一个二叉搜索树(BST)按照以下规则递归的定义的一棵二叉树:
1.左子树仅仅包括键值小于该点键值的点。
2.右子树仅仅包括键值大于等于该点键值的点。
3.左子树和右子树均为二叉搜索树树。
一个完全二叉树(CBT)是一棵完全充满的数,只有最底层可能有空缺,并且由左向右插入。
现在给你一个由唯一的非负整数键值组成的数列,我们需要构建一个特殊的BST,即它同时还是一棵完全二叉树。你需要输出BST的按照层级遍历的数列。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数N(<=1000)。接着在下一行给出N个唯一的非负整数键值。一行内所有数字之间用空格隔开,并且不超过2000。

OUTPUT FORMAT

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

翻译:对于每组输入数据,输出一行按照水平顺序输出完全二叉搜索树的数列。一行内所有数字直接用空格隔开,并且行末尾不能有多余空格。


Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4


解题思路

这道题并不需要建立树,只需要计算出每棵树的根节点位置即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
int N;
int d[1010];
int fun(int a){
    int temp=2;
    while(a>temp-1){
        temp*=2;
    }
    if(a-temp/2+1<temp/4)return a-temp/4+1;
    else return temp/2;
}
typedef pair<int,int> P;
queue<P> q;
void bfs(){
    int flag=0;
    while(!q.empty()){
        P temp=q.front();q.pop();
        int t=fun(temp.second-temp.first+1)+temp.first-1;
        if(flag==0)printf("%d",d[t]),flag=1;
        else printf(" %d",d[t]);
        if(t>temp.first)q.push(P(temp.first,t-1));
        if(t<temp.second)q.push(P(t+1,temp.second));
    }
}
int main(){
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    scanf("%d",&d[i]);
    sort(d,d+N);
    q.push(P(0,N-1));
    bfs();
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值