Common Subsequence HDU - 1159( 动态规划 最长公共子序列)

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Input

abcfbc abfcab
programming contest 
abcd mnp

Output

4
2
0

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

思路:

理解下面图片的内容就可以AC啦!
在这里插入图片描述

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[10000],b[10000];
int dp[1000][1000];
int main()
{
    while(~scanf("%s %s",a+1,b+1))
    {
        memset(dp,0,sizeof(dp));
        int i,j;
        int l=strlen(a+1);
        int l1=strlen(b+1);
        for(i=1; i<=l; i++)
            dp[i][0]=0;
        for(j=1; j<=l1; j++)
            dp[0][j]=0;
        int maxx=0;
        for(i=1; i<=l; i++)
        {
            for(j=1; j<=l1; j++)
            {
                if(a[i]==b[j])
                    dp[i][j]=dp[i-1][j-1]+1;
                //加上下面的else语句表示求的是非连续的,删掉求出的则是连续的
                else 
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                maxx=max(dp[i][j],maxx);//放在for循环内每次要更新
            }

        }
        printf("%d\n",maxx);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值