Max Sum HDU - 1003( 最大子序列和 )

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

题意:

给你一组数据,求这组数据的最大子序列和,并且输出子序列的开始与结束下标

思路:

对数组求和,依次判断,如果前面的几个数据都为负数加起来小于0,那么舍去这些数据,让和为0,从下一个整数或0开始,让其作为子序列的起始下标,然后依次判断,当然,可能出现样例全负的情况,那么我们就要输出最大的负数以及它的下标,但是这个不需要特判,正常写代码即可(也不要被其他类似的题影响,有的题可能和这个一样,但是规定的是如果全负的话输出0 一定要好好看题目的要求啊 否则真的让人很悲伤啊!)

代码:

#include<stdio.h>
int a[100010];
int main()
{
    int t;
    scanf("%d",&t);
    int k=0;   //此题不需要特判!如果全是负数,也正常计算
    while(t--)
    {
        k++;
        int n,i;
        scanf("%d",&n);
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
        int s=0,b=1;
        int head=1,tail=1;
        int maxx=-999999;9
        for(i=1; i<=n; i++)
        {
            s=s+a[i];
            if(s>maxx)
            {
                maxx=s;   //更新maxx的值以及子序列的起始与结束下标
                head=b;
                tail=i;
            } 
            //第一个if与第二个if不可以交换位置!!交换位置输出的答案是不一样的你可以试试
            if(s<0)
            {
                s=0;
                b=i+1;
            }
        }
        printf("Case %d:\n",k);
        printf("%d %d %d\n",maxx,head,tail);
        if(t>0)   //输出控制两个例子之间一个空行
            printf("\n");

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值