Packets POJ - 1017 ( 贪心+大箱子装小箱子)

A factory produces products packed in square packets of the same height h and of the sizes 1 * 1, 2* 2, 3* 3, 4* 4, 5* 5, 6* 6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 11 to the biggest size 66. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null’’ line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

题意:

用66的箱子装给定数量的1 1,2* 2,3* 3,4 * 4 ,5 * 5,6* 6的箱子,h
可不考虑,计算最少需要用多少个6*6的箱子才可以将所有的箱子都装进去。

思路:

立体问题化为平面问题解决

一个6*6的箱子可装的箱子类型可装的箱子数量
6*61
5*51个+11个1*1
4*41个+5个2*2
3*34个
2*29个
1*136个

图如下
在这里插入图片描述

在这里插入图片描述
在这里插入图片描述

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int a,b,c,d,e,f,x,y;
    //  1 2 3 4 5 6 2 1
    int p[4]= {0,5,3,1};//装n个3*3箱子后还可装几个2*2的箱子,n为0 1 2 3
    while(~scanf("%d %d %d %d %d %d",&a,&b,&c,&d,&e,&f)&&a+b+c+d+e+f)
    {
        int s;
        s=f+e+d+(c+3)/4;//3*3 4*4 5*5 6*6都需一个单独的6*6箱子
        x=d*5+p[c%4];//装d个4*4的箱子可以再装5*d个2*2的箱子+装3*3的箱子里面可以再装2*2的箱子数量
        if(b>x)//箱子装不够,需要在用新的6*6的箱子装2*2的箱子
            s=s+(b-x+8)/9;
        y=36*s-36*f-25*e-16*d-9*c-4*b;//已经装好的1*1的箱子的数量
        if(a>y)
            s=s+(a-y+35)/36;//不够装在拿新的箱子
        printf("%d\n",s);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值