有一种特殊的日历法,它的一天和我们现在用的日历法的一天是一样长的。它每天有10个小时,每个小时有100分钟,每分钟有100秒。10天算一周,10周算一个月,10个月算一年。现在要你编写一个程序,将我们常用的日历法的日期转换成这种特殊的日历表示法。这种日历法的时、分、秒是从0开始计数的。日、月从1开始计数,年从0开始计数。秒数为整数。假设 0:0:0 1.1.2000 等同于特殊日历法的 0:0:0 1.1.0。
Input
第一行是一个正整数 N ,表明下面有 N 组输入。每组输入有一行,格式如下:hour:minute:second day.month.year
表示常规的日期。日期总是合法的。2000 <= year <= 50000。
Output
每组输入要求输出一行。格式如下:mhour:mmin:msec mday.mmonth.myear 是输入日期的特殊日历表示方法。
Sample Input
7
0:0:0 1.1.2000
10:10:10 1.3.2001
0:12:13 1.3.2400
23:59:59 31.12.2001
0:0:1 20.7.7478
0:20:20 21.7.7478
15:54:44 2.10.20749
Sample Output
0:0:0 1.1.0
4:23:72 26.5.0
0:8:48 58.2.146
9:99:98 31.8.0
0:0:1 100.10.2000
0:14:12 1.1.2001
6:63:0 7.3.6848
思路:
先根据我们正常的一年12个月,一天24小时一小时60分钟一分钟60秒算出总天数与总秒数,然后日期和时间是分开考虑的,注意判断闰年的2月,时间是根据比例来算的,最后再按照题中所给的日历表示法计算输出即可。
代码中0.864的来源:
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int month[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int sum[20];
int judge(int y)
{
if(y%400==0||(y%4==0&&y%100!=0))
return 1;
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int a,b,c,d,e,f;
scanf("%d:%d:%d %d.%d.%d",&a,&b,&c,&d,&e,&f);
for(int i=1; i<=12; i++)
sum[i]=sum[i-1]+month[i-1];
int Sums=a*60*60+b*60+c;//总秒数
int s=0;
for(int i=2000; i<f; i++)
{
if(judge(i)==1)
s+=366;
else
s+=365;
}
int Sumd;//总天数
if(judge(f)&&e>2)
Sumd=d+sum[e]+1+s;
else
Sumd=d+sum[e]+s;
int seconds=Sums/0.864;
Sumd=Sumd-1;
printf("%d:%d:%d %d.%d.%d\n",seconds/10000,(seconds/100)%100,seconds%100,Sumd%100+1,Sumd/100%10+1,Sumd/1000);
}
return 0;
}