Goldbach

Description:

Goldbach's conjecture is one of the oldest and best-known unsolved problems in number theory and all of mathematics. It states:

Every even integer greater than 2 can be expressed as the sum of two primes.

The actual verification of the Goldbach conjecture shows that even numbers below at least 1e14 can be expressed as a sum of two prime numbers. 

Many times, there are more than one way to represent even numbers as two prime numbers. 

For example, 18=5+13=7+11, 64=3+61=5+59=11+53=17+47=23+41, etc.

Now this problem is asking you to divide a postive even integer n (2<n<2^63) into two prime numbers.

Although a certain scope of the problem has not been strictly proved the correctness of Goldbach's conjecture, we still hope that you can solve it. 

If you find that an even number of Goldbach conjectures are not true, then this question will be wrong, but we would like to congratulate you on solving this math problem that has plagued humanity for hundreds of years.

Input:

The first line of input is a T means the number of the cases.

Next T lines, each line is a postive even integer n (2<n<2^63).

Output:

The output is also T lines, each line is two number we asked for.

T is about 100.

本题答案不唯一,符合要求的答案均正确

样例输入
1
8
样例输出
3 5
#include<bits/stdc++.h>
#define fi first
#define se second
#define mp make_pair
#define pb push_back
#define fin(x) freopen(x,"r",stdin)
#define fout(x) freopen(x,"w",stdout)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef unsigned long long ll;
typedef pair<int,int> pii;
const ll INF=0x3f3f3f3f3f3f3f3f;
const ll inf=0xc0c0c0c0c0c0c0c0;
const double pi=acos(-1);
const int S = 10;
const int MAX=1e7+7;
bool com[MAX];  
ll primes, prime[MAX/10]; 
map<ll,bool> maze;
void solve()  
{  
    primes = 0;  
    memset(com,false,sizeof(com));  
    com[0] = com[1] = true;  
    for (int i = 2; i <= MAX; ++i)  
    {  
        if (!com[i])  
        {  
            prime[++primes] = i;  
            maze[i]=1;
        }  
        for (int j = 1; j <= primes && i*prime[j] <= MAX; ++j)  
        {  
            com[i*prime[j]] = true;  
            if (!(i % prime[j]))  
                break;  
        }  
    }  
}  




ll mult_mod(ll a,ll b,ll  c)
{
    a %= c;
    b %= c;
    ll ret = 0;
    ll tmp = a;
    while(b)
    {
        if(b & 1)
        {
            ret += tmp;
            if(ret > c)ret -= c;
        }
        tmp <<= 1;
        if(tmp > c)tmp -= c;
        b >>= 1;
    }
    return  ret;
}
ll pow_mod(ll a,ll n,ll  mod)
{
    ll ret = 1;
    ll temp = a%mod;
    while(n)
    {
        if(n & 1)ret = mult_mod(ret,temp,mod);
        temp = mult_mod(temp,temp,mod);
        n >>= 1;
    }
    return  ret;
}
bool check(ll a,ll n,ll x,ll  t)
{
    ll ret = pow_mod(a,x,n);
    ll last = ret;
    for(int i = 1; i <= t; i++)
    {
        ret = mult_mod(ret,ret,n);
        if(ret == 1 && last != 1 && last != n-1)return  true;
        last = ret;
    }
    if(ret != 1)return true;
    else return false;
}
bool Miller_Rabin(ll  n)
{
    if( n < 2)return false;
    if( n == 2)return true;
    if( (n&1) == 0)return false;
    ll x = n - 1;
    ll t = 0;
    while( (x&1)==0 )
    {
        x >>= 1;
        t++;
    }
    srand(time(NULL));/* *************** */
    for(int i = 0; i < S; i++)
    {
        ll a =  rand()%(n-1) + 1;
        if( check(a,n,x,t) )
            return false;
    }
    return true;
}


int main()
{
	solve();
	//random_shuffle(prime+1,prime+primes+1);
	int T;
	scanf("%d",&T);
	while(T--)
	{
		ll x;
		scanf("%lld",&x);
		if(x<MAX) {
			for(int i=1;i<=primes && prime[i]<=x;i++) {
				if(maze[x-prime[i]]) {
					printf("%lld %lld\n",prime[i],x-prime[i]);
					break;
				}
			}
			continue;
		}
		for(int i=1;i<=primes;i++) {
			ll a;
			ll b;
			a=prime[i];
			b=x-a;
			if(Miller_Rabin(b))
			{
				printf("%lld %lld\n",a,b);
				break;
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值