Goldbach`s Conjecture(素数筛)

题目链接

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 10^7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 10^7, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

  1.  Both a and b are prime
    
  2.  a + b = n
    
  3.  a ≤ b
    

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

  1. An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …

这道题的大致意思是给你T行,每行有1个数字N,要求你去算 多少个 a + b=N?其中 a 和 b 是素数,同时a要小于等于b。
这道题是道比较水的题目,可是我在这道题上疯狂re,也不知道是怎么一回事,然后上网翻博客,发现Lightoj要求的是32Mb,只要将其中一个数组类型改为bool类型就可以了,我傻了,还是题目做的少。
那么具体代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=10000005;
int prime[maxn\10];
bool v[maxn];
int m;
void init(){
    for(int i=1;i<maxn;i++){ 
        v[i]=0;
    }
    m=0;
    for(int i=2;i<maxn;i++){ 
        if (!v[i])prime[++m]=i;
        for(int j=1;j<=m;j++){ 
            if (i*prime[j]>=maxn)break;
            v[i*prime[j]]=1;
            if (i%prime[j]==0)break;
        }
    }
}
int main(){
    init();
    v[1]=1;
    int t;
    scanf("%d", &t);
    int Case=0;
    while(t--){ 
        int n;
        scanf("%d", &n);
        int cnt=0;
        for(int i=1;i<=m;i++){ 
            // cout<<prime[i]<<endl;
            if (prime[i]>n/2)break;
            if (n-prime[i]>0&&!v[n-prime[i]]){ 
                // cout<<prime[i]<<endl;
                cnt++;
            }
        }
        printf("Case %d: %d\n", ++Case, cnt);
    }
}

道阻且长
自己选的路 跪着也要走完

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值