Goldbach`s Conjecture

Goldbach`s Conjecture

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input
Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

  1.  Both a and b are prime
    
  2.  a + b = n
    
  3.  a ≤ b
    

Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Note
An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …

大意

你的任务是找到最小自然数n,这样n!以十进制记数法精确包含尾迹上的Q零。如你所知,N!=12…*n。例如,5!=120,120在轨迹上包含一个零。

输入
输入以整数t(≤10000)开始,表示测试用例的数量。

每种情况都包含一行中的整数q(1≤q≤108)。

产量
对于每个案例,打印案例编号和n。如果没有找到解决方案,则打印“不可能”。

思路

求n=a+b且a,b都是素数这样的ab的对数。只要素筛一下,就能做了。最好先储存一下10^7以内的素数,数答案时只要到n/2就行了(因为a<=b)

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
bool a[10000001];
int prime[700000];
int main()
{
    int i,j,h,n,T,num,k=1,l=0;
    for(i=2; i<=10000000; i++)
    {
        if(a[i]==false)
        {
            prime[l++]=i;
            for(j=i+i; j<=10000000; j=j+i)
                a[j]=true;
        }
    }
    a[0]=a[1]=true;
    scanf("%d",&T);
    while(T--)
    {
        num=0;
        scanf("%d",&n);
        for(i=0; i<l; i++) 
        {
            if(prime[i]>=n/2+1)
                break;
            h=n-prime[i];
            if(a[h]==false)
            {
                num++;
            }
        }
        printf("Case %d: %d\n",k++,num);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值