算法学习:拓扑排序(poj1094)

所谓拓扑排序,即在有向图中,找出一个没有入度的点,将他与他所有的出度从图中删去(即所有与它相连的点的入度-1)直到所有点被输出或找不到入度为零的点为止。


例:题目:POJ1094

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:给出前n个大写英文字母的相关关系,问能否给出排序

方法:

1.找环,若找到环,则发生冲突,

2.若在读完前几条后已经能确定关系,则无需处理后面的矛盾(如n=2,m=2,A<B,B<A)则不会产生矛盾,


3。若读完所有关系仍不能确定顺序,则输出无法确定。

源程序:

//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int M[30][30],indegree[30],n,m;
char A,B,t;
char ans[30];

int TopoSort()     //拓扑排序
{
    int c=0,temp[27],loc,cnt,flag=1;
    for(int i=1;i<=n;i++)
        temp[i]=indegree[i];
    for(int i=1;i<=n;i++)
    {
        cnt=0;
        for(int j=1;j<=n;j++)
            if(temp[j]==0)
            {
                cnt++;
                loc=j;
            }
        if(cnt==0)            //没有点入度为0,成环
            return -1;
        if(cnt>1)               //有多个点入度为0,无法确定顺序
            flag=0;
        ans[c++]=char(loc+'A'-1);
        temp[loc]=-1;
        for(int j=1;j<=n;j++)
            if(M[loc][j]==1) temp[j]--;
    }
    return flag;         //若flag==1,则确定了顺序
}

int main()
{
    scanf("%d%d",&n,&m);
    while(n && m)
    {
        for (int i=0;i<30;i++)
            ans[i]='\0';
        memset(M,0,sizeof(M));
        memset(indegree,0,sizeof(indegree));
        int flag=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%c%c%c%c",&t,&A,&t,&B);
            if (flag)
                continue;
            int x=A-'A'+1;
            int y=B-'A'+1;
            M[x][y]=1;
            indegree[y]++;      //无入度的字母最小
            flag=TopoSort();
            if(flag==1)
            {
                printf("Sorted sequence determined after %d relations: ",i);
                printf("%s",ans);
                printf(".\n");
            }
            if(flag==-1)
            {
                printf("Inconsistency found after %d relations.\n",i);
                flag=1;
            }

        }
        if(!flag)
            printf("Sorted sequence cannot be determined.\n");
        scanf("%d%d",&n,&m);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值