HDU 2669 算法学习:exgcd 拓展欧几里得

题目:

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5762    Accepted Submission(s): 2456


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

Sample Input
  
  
77 51 10 44 34 79
 
Sample Output
  
  
2 -3 sorry 7 -3

拓展欧几里得算法运用于解形如ax+by=p的方程的一组解,注意是一组解。所以在处理扩展欧几里得算法的题目时,要注意题目对解的要求。
此题要求一组使ax+by=1且x正数,且x最小的解。注意,gcd(a,b)%p=0。故a,b应该互质
具体实现见程序。

程序:
//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a,b,ansa,ansb;

void exgcd(int aa,int bb,int &x,int &y)     //拓展欧几里得算法模板
{
    if (bb==0)
    {
        x=1;
        y=0;
        return;
    }
    else
    {
        exgcd(bb,aa%bb,y,x);
        y-=(aa/bb)*x;
        return;
    }
}

int gcd(int x,int y)
{
    if (y==0)
        return x;
    return (gcd(y,x%y));
}
int main()
{
    while (scanf("%d%d",&a,&b)!=EOF)
    {
        int g=gcd(a,b);
        if (g!=1)          //a,b 不互质,无解
        {
            printf("sorry\n");
            continue;
        }
        exgcd(a,b,ansa,ansb);
        while (ansa<0)          //找到最小非负解
        {
            ansa+=b;
            ansb-=a;
        }
        while (ansa>0)
        {
            ansa-=b;
            ansb+=a;
        }
        if (ansa<0)
        {
            ansa+=b;
            ansb-=a;
        }
        printf("%d %d\n",ansa,ansb);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值