kuangbin 最短路 H题(如何将看似拓扑的问题转化成floyd )

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output 2

题意:告诉你N只牛之间部分的两两胜负关系,求有几只牛的位置是确定的。

思路:此题看似为拓扑,但若使用拓扑排序,如何判断位置是否确定就是件很麻烦的事情。
这里,我们可以看出,如果A赢了B,B赢了C,则A就赢了C。此处很有floyd算法中dist[i][j]=min(dist[i][j],dist[i][k]+dist[k][j])的感觉。
使用floyd算法,当一只牛与其他牛的胜负关系确定了,那么这头牛的位置也就确定了。

代码:
//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

int Map[105][105];    //牛与牛之间的胜负关系,0表示无关系,1表示A赢B,-1表示A输B
int n,m,a,b;

int main()
{
    scanf("%d%d",&n,&m);
    for (int i=0;i<m;i++)
    {
        scanf("%d%d",&a,&b);
        Map[a][b]=1;
        Map[b][a]=-1;
    }
    for (int k=1;k<=n;k++)
        for (int i=1;i<=n;i++)
            for (int j=1;j<=n;j++)
            {
                if (Map[i][k]==1 && Map[k][j]==1)
                    Map[i][j]=1;          //i赢j
                if (Map[i][k]==-1 && Map[k][j]==-1)
                    Map[i][j]=-1;         //i负于j
            }
    int ans=0;
    for (int i=1;i<=n;i++)
    {
        int flag=1;
        for (int j=1;j<=n && flag;j++)
        {
            if (i!=j && Map[i][j]==0)
                flag=0;
        }
        ans+=flag;
    }
    cout<<ans<<endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值