Connections in Galaxy War并查集+set+脑洞

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.


Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

  • "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input
2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output
1
-1
-1
-1
很明显,这是一道并查集的题目,但是,这道题有两个难点。1、如何删除路径;2、如何找到并查集中权值最大的点。
对于删除路径这个问题,我们可以采用反向的方法。先读入所有的操作,并完成删边的操作后,将剩下的边加入并查集中。然后从后往前进行查询,遇到delete a b的时候,就将这两个节点加入并查集,这样就保证了每次query时,并查集的状态是不变的,也方便加边。
2、查找并查集中权值最大的点:我们在合并并查集的时候,可以进行处理,将满足要求的权值最大的点放至根节点。这样,我们查找权值最大的点只需直接查找根节点即可。

代码:
//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <set>

using namespace std;
int Q[50005][2];
int root[10005],power[10005],ans[50005];
int n,m,p,a,b;

int findroot(int x)
{
    if (x==root[x])
        return x;
    return (root[x]=findroot(root[x]));
}

void Uni(int x,int y)
{
    int xx=findroot(x),yy=findroot(y);
    if (xx!=yy)
    {
        if (power[xx]>power[yy])           //合并时保证根节点为满足要求的power最大的节点
        {
            root[yy]=xx;
        }
        else if (power[xx]<power[yy])
        {
            root[xx]=yy;
        }
        else
        {
            if (xx>yy)
                root[xx]=yy;
            else
                root[yy]=xx;
        }
    }
    return;
}

int flag=0;
int main()
{
    while (scanf("%d",&n)!=EOF)
    {
        if (flag)
            cout<<endl;
        flag=1;
        set <int> S[50005];
        for (int i=0;i<n;i++)
        {
            root[i]=i;
            scanf("%d",&power[i]);
        }
        scanf("%d",&p);
        for (int i=0;i<p;i++)
        {
            scanf("%d%d",&a,&b);
            if (a>b)
            {
                int t=a;
                a=b;
                b=t;
            }
            S[a].insert(b);          //使用set方便查找和删除
        }
        char str[10];
        scanf("%d",&m);
        for (int i=0;i<m;i++)        //记录输入的操作
        {
            scanf("%s",str);
            if (str[0]=='q')
            {
                scanf("%d",&a);
                Q[i][0]=a;
                Q[i][1]=-1;
            }
            else
            {
                scanf("%d%d",&a,&b);        //删除边
                if (a>b)
                {
                    int t=a;
                    a=b;
                    b=t;
                }
                Q[i][0]=a;
                Q[i][1]=b;
                S[a].erase(S[a].find(b));
            }
        }
        
        for (int i=0;i<n;i++)      //将未删除的边加入并查集
        {
            for(set<int>::iterator it=S[i].begin();it!=S[i].end();it++)
                Uni(i,*it);
        }
        
        for (int i=m-1;i>=0;i--)         //反向
        {
            if (Q[i][1]==-1)
            {
                int temp=findroot(Q[i][0]);
                if (power[temp]<=power[Q[i][0]])
                    ans[i]=-1;
                else
                    ans[i]=temp;
            }
            else        //加入并查集
            {
                Uni(Q[i][0],Q[i][1]);
                ans[i]=-2;
            }
        }
        for (int i=0;i<m;i++)
        {
            if (ans[i]!=-2)
                printf("%d\n",ans[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值