ZOJ 3261 Connections in Galaxy War(并查集+思维+STL数据结构)

2 篇文章 0 订阅
2 篇文章 0 订阅

ZOJ Problem Set - 3261
Connections in Galaxy War
Time Limit: 3 Seconds Memory Limit: 32768 KB
In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn’t find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, … , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It’s guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

“destroy a b” - the connection between star a and star b was destroyed by the monsters. It’s guaranteed that the connection between star a and star b was available before the monsters’ attack.

“query a” - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output “-1”; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1
Sample Output

1
-1
-1
-1
Author: MO, Luyi
Source: ZOJ Monthly, November 2009

题意:给N个星球,每个星球的力量为Pi,M条边,有Q条两种操作,删去一条边和查询这个星球能连到的力量比它自身要大的点里力量最大的点,如果没有则输出-1

做法:看看这就是逆向的畅通工程水题,逆向思维,先把操作读入,看删完边后还剩多少,从最后一条操作开始执行,每删去一条,就连接这个边的端点,保存答案,最后输出,代码量有些大

注意:vector 的 erase函数用法

e.erase(e.begin()+i);
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <vector>
#define maxn 10010
int n,m,q;
int pre[maxn];
long long  p[maxn];
using namespace std;
struct Node
{
    int q,a,b;
}node[50050];
struct Edge
{
    int a,b;
};
vector<Edge> e;
void de(int a,int b)
{
    for(int i=0;i<e.size();i++)
    {
        if((e[i].a==a&&e[i].b==b)||(e[i].a==b&&e[i].b==a))
        {e.erase(e.begin()+i);return;}
    }
}

void init()
{
    for(int i=0;i<=n;i++)
    {
        pre[i]=i;
    }
}
int fr(int x)
{
    int r=x;
    while(r!=pre[r])
    {
        r=pre[r];
    }
    int j=x;
    while(x!=r)
    {
        j=pre[x];
        pre[x]=r;
        x=j;
    }
    return r;
}

bool cmp(int i,int j)
{
    if(p[i]==p[j])return i<j;
    return p[i]>p[j];
}
void join(int x,int y)
{
    int r1=fr(x);
    int r2=fr(y);
    if(r1!=r2)
    {
        if(cmp(r1,r2))
        {
            pre[r2]=r1;
        }
        else pre[r1]=r2;
    }
}
int main()
{
    stack<int> ans;
    bool first=false;
    while(scanf("%d",&n)!=EOF)
    {
        if(first){
            printf("\n");
        }
        first=true;
    for(int i=0;i<n;i++)
    {
        scanf("%lld",&p[i]);
    }
    init();
    e.clear();
    scanf("%d",&m);
    int a,b;
    Edge sar;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d",&a,&b);
        sar.a=a;
        sar.b=b;
        e.push_back(sar);

    }
    scanf("%d",&q);
    char str[10];
    for(int i=0;i<q;i++)
    {
        scanf("%s",&str);
        if(str[0]=='d')
        {
            scanf("%d%d",&a,&b);
            de(a,b);
            node[i].q=0;
            node[i].a=a;
            node[i].b=b;
        }
        else
        {
            scanf("%d",&a);
            node[i].a=a;
            //cout<<" a "<<a<<endl;
            node[i].b=-1;
            node[i].q=1;
        }
    }
//    cout<<"q "<<q<<endl;
    for(int i=0;i<e.size();i++)
    {
        join(e[i].a,e[i].b);
    }
    Node cur;
    for(int i=q-1;i>=0;i--)
    {
        cur=node[i];
        if(cur.q==0)join(cur.a,cur.b);
        else
        {
            int r=fr(cur.a);
            if(r==cur.a||p[r]==p[cur.a])ans.push(-1);
            else ans.push(r);
        }
    }
    while(!ans.empty())
    {
        printf("%d\n",ans.top());
        ans.pop();
    }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值