次小生成树 ACM Contest and Blackout

题目:

Problem A

ACM contest and Blackout

 

In order to prepare the “The First National ACM School Contest”(in 20??) the major of the city decided to provide all the schools with a reliable source of power. (The major is really afraid of blackoutsJ). So, in order to do that, power station “Future” and one school (doesn’t matter which one) must be connected; in addition, some schools must be connected as well.

 

You may assume that a school has a reliable source of power if it’s connected directly to “Future”, or to any other school that has a reliable source of power. You are given the cost of connection between some schools. The major has decided to pick out two the cheapest connection plans – the cost of the connection is equal to the sum of the connections between the schools. Your task is to help the major – find the cost of the two cheapest connection plans.

 

Input

The Input starts with the number of test cases, T (1?T?15) on a line. Then T test cases follow. The first line of every test case contains two numbers, which are separated by a space, N (3?N?100) the number of schools in the city, and M the number of possible connections among them. Next M lines contain three numbers Ai, Bi, Ci , where Ci  is the cost of the connection (1?Ci?300) between schools Ai  and Bi. The schools are numbered with integers in the range 1 to N.

 

Output

For every test case print only one line of output. This line should contain two numbers separated by a single space - the cost of two the cheapest connection plans. Let S1 be the cheapest cost and S2 the next cheapest cost. It’s important, that S1=S2 if and only if there are two cheapest plans, otherwise S1?S2. You can assume that it is always possible to find the costs S1 and S2..

 

Sample Input

Sample Output

2

5 8

1 3 75

3 4 51

2 4 19

3 2 95

2 5 42

5 4 31

1 2 9

3 5 66

9 14

1 2 4

1 8 8

2 8 11

3 2 8

8 9 7

8 7 1

7 9 6

9 3 2

3 4 7

3 6 4

7 6 2

4 6 14

4 5 9

5 6 10

110 121

37 37

题意:找出图中的最小生成树和次小生成树。

次小生成树是这样产生的:先通过最小生成树,标记产生最小生成树的每一条边,然后去掉最小生成树中任意一条边,并再次计算最小生成树。取最小值,便是次小生成树。

代码:

//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define inf 0x3f3f3f3f
using namespace std;

struct edge{
    int s,e,length,pos;
};

int cmp(edge a,edge b)
{
    return a.length<b.length;
}

int root[105];
edge Map[10005];
int rec[105];
int T,n,m;

int findroot(int x)
{
    if (x==root[x])
        return x;
    return root[x]=findroot(root[x]);
}

void Uni(int a,int b)
{
    int ra=findroot(a),rb=findroot(b);
    if (ra!=rb)
        root[ra]=rb;
    return;
}

int prim(int pos)            //pos表示去掉的那一条边的编号,pos==-1时,即为最小生成树
{
    int ans=0;
    int flag=1;
    int cnt=0;
    for (int i=1;i<n;i++)
    {
        edge temp=Map[cnt];
        while ((findroot(temp.s)==findroot(temp.e) || temp.pos==pos) && cnt<m)      //去掉的边不可再次使用
        {
            cnt++;
            temp=Map[cnt];
        }
        if (cnt==m)           //无法实现最小/次小生成树
            return -1;
        if (pos==-1)          //记录最小生成树
            rec[i]=temp.pos;
        cnt++;
        ans+=temp.length;
        Uni(temp.s,temp.e);
    }
    return ans;
}
int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d%d",&n,&m);
        for (int i=1;i<=n;i++)
            root[i]=i;
        for (int i=0;i<m;i++)
        {
            scanf("%d%d%d",&Map[i].s,&Map[i].e,&Map[i].length);
            Map[i].pos=i;
        }
        sort(Map,Map+m,cmp);
        int ans1=prim(-1);        //最小生成树
        int ans2=inf;
        for (int i=1;i<n;i++)
        {
            for (int j=1;j<=n;j++)
                root[j]=j;
            int tmp=prim(rec[i]);        //去掉一条边,找次小生成树
            if (tmp!=-1 && tmp<ans2)
                ans2=tmp;
        }
        cout<<ans1<<' '<<ans2<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值