哈希算法---Snowflake Snow Snowflakes

本文深入探讨了Snowflake算法,一种由Twitter提出的分布式ID生成方案。它通过结合时间戳、工作节点ID和序列号,生成全局唯一的64位ID。这种算法避免了哈希冲突,并且在分布式系统中具有高效性和低延迟的特性。同时,文章还介绍了如何在实际项目中实现和优化Snowflake算法,以及与其他哈希算法如链表和头插法的对比。
摘要由CSDN通过智能技术生成



You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.

Status Accepted
Time 3188ms
Memory 45372kB
Length 1098
Lang G++
Submitted

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
using namespace std;
struct number{
	int arms[6];
	struct number *next;
}; 
struct number *Hash[10000007];
int num[6];
int n,sum,flag;
void judge(int a[],int sum)
{
	
	struct number *p;
	//struct number *temp,*head;
	sum=sum%10000000;
	p=Hash[sum];
	while(p)
	{
		if(p->arms[0]==a[0]&&p->arms[1]==a[1]&&p->arms[2]==a[2]&&p->arms[3]==a[3]&&p->arms[4]==a[4]&&p->arms[5]==a[5])
		{
			flag=1;	return;
		}
		//temp=p;
		p=p->next;
	}
	p=(struct number *)malloc(sizeof(struct number));
	for(int i=0;i<6;i++)
		p->arms[i]=a[i];
	p->next=Hash[sum];
	Hash[sum]=p;
	//temp->next=p;
}
int main()
{
	std::ios::sync_with_stdio(false);
	int t,time;
	scanf("%d",&n);
	flag=0;
	memset(num,0,sizeof(num));
	for(int j=0;j<n;j++)
	{
		sum=0;
		for(int i=0;i<6;i++)
		{
			scanf("%d",&num[i]);	//此处换成cin  就会超时 
			sum+=num[i];
		}
	
		if(!flag)
		{
			sort(num,num+6);
			//COUNT=0;
			judge(num,sum);
		}
			
	}
	if(!flag)
		printf("No two snowflakes are alike.\n");
	else 
		printf("Twin snowflakes found.\n");
	return 0;
}





























































评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值