Snowflake Snow Snowflakes(哈希表)

SnowflakeSnowSnowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 39744 Accepted: 10422

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source


解题思路:

雪花有六个角,每个角有一个长度,按顺时针或者逆时针给出,起点是随机的。两个雪花相同当且仅当每个角的长度一样,且必须是连续的,比如   2 3 1  4 5 6 和 2 1 3  4 5 6就不行,1 2 3 4 5 6    4 3 2 1 6 5是一样的(第二个逆时针给出)。给出一堆雪花的六个角的长度,问这里面能不能找到两个相同的雪花。

1. 两个雪花相同的前提条件是,它们雪花六个角的长度和相等。 把每个雪花按照长度映射到哈希表中。这里哈希表用 vector< int> s[]. 当 s[i].size()>1时,说明s[i][j] 和s[i][k]有可能是两个相同的雪花,只要在hs[i]里面查找就可以了。

2. 怎么判断两个雪花a,b相同?分两步,一, 固定a,用b的每个边和a的第一条边对齐,然后顺时针比较a,b的每一条边。二,固定a,用b的每个边和a的第一条边对齐,然后逆时针比较a,b的每一条边。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cstdio>
#define N 100010
using namespace std;
vector<int>s[N];//建立哈希表容器
int a[N][6];
int n;
int check(int x,int y)
{   int i,j;
    for(i=0;i<6;i++)
    {
        if(a[x][i]==a[y][0])
        {
           for(j=0;j<6;j++)
           {
               if(a[x][(i+j)%6]!=a[y][j])
               break;
           }
           if(j==6)return 1;
           for(j=0;j<6;j++)
           {
               if(a[x][(i+j)%6]!=a[y][(6-j)%6])
               break;
           }
           if(j==6)
           return 1;
        }
    }
    return 0;
}
int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        int sum=0;
        for(int j=0;j<6;j++)
        {scanf("%d",&a[i][j]);
         sum=(sum+a[i][j])%N;//sum是长度,只有sum相同的两片雪花才可能相等
        }
        s[sum].push_back(i);//在sum位置存入第i个雪花
    }
    int flag=0;
    for(int i=0;i<N;i++)//全部遍历
    {
        for(int j=0;j<(int)s[i].size()-1;j++)
        {
            for(int k=j+1;k<(int)s[i].size();k++)//比较第j个和其下一个
            {
                if(check(s[i][j],s[i][k]))//i之前存的是sum,第sum位置的雪花,s[i][j],s[i][k],是整数之前存的i值
                flag=1;//有两片一样的
            }
        }
    }
    if(flag)
    printf("Twin snowflakes found.\n");
    else printf("No two snowflakes are alike.\n");
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值