哈希算法---Babelfish

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint
Huge input and output,scanf and printf are recommended.

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
struct String{
	char fact[15];
	char word[15];
}; 
struct String Hash[100007];
int num, i,j,k;
char str[25];
int compar(const void *a, const void *b) {
	struct String *a1=(struct String *)a;
	struct String *b1=(struct String *)b;
   return strcmp(a1->word,b1->word);
}
//bsearch代码实现:
int binary_search(int len,char str[])
{
    int low=0;
    int high=len-1;
    while (low<=high)
    {
        int middle=(high-low)/2+low; // 直接使用(high + low) / 2 可能导致溢出int 最大范围 
        if (strcmp(Hash[middle].word,str)==0)
        {
        	//cout<<middle<<endl;
        	//cout<<Hash[middle].word<<" "<<str<<endl;
        	return middle;
		}
            
        //在左半边
        else if (strcmp(Hash[middle].word,str)>0)
            high=middle-1;
        //在右半边
        else
            low=middle+1;
    }
    //没找到
    return -1;
} 
int main()
{
	num=0;
   	while (gets(str)&&str[0]) 
   	{
      	sscanf(str,"%s %s",Hash[num].fact,Hash[num].word);
      	num++;
   	}
   	qsort(Hash,num,sizeof(struct String),compar); 
   	while (gets(str)&&str[0]) 
   	{
   		//puts(str); 
      	int p;
      	p=binary_search(num,str);
      	if(p!=-1) printf("%s\n",Hash[p].fact);
      	else printf("eh\n");
   }
   return 0;
}



Time limit
3000 ms
Memory limit
65536 kB
OS
Linux



Status Accepted
Time 391ms
Memory 3100kB
Length 1302
Lang C++
Submitted

















































  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值