HDU 6322 Euler Function

Problem Description

In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n . It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1 .
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9 . As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1 itself, and gcd(1,1)=1 .
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k , your task is to find the k -th smallest positive integer n , that φ(n) is a composite number.

 

Input

The first line of the input contains an integer T(1≤T≤100000) , denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109) .

 

Output

For each test case, print a single line containing an integer, denoting the answer.

 

Sample Input

2

1

2

Sample Output

5

7

题目大意:介绍了一下欧拉函数的定义与合数的定义(欧拉函数:https://baike.baidu.com/item/欧拉函数/1944850?fr=aladdin  合数:https://baike.baidu.com/item/合数/49186)然后要求输出欧拉函数中的第k个合数。

思路:这道题是签到题,看完题第一反应是打表直接找,但是,这样肯定是超时的(我做题一般都不怎么带脑子),所以应该找规律,从合数的定义可以得出,,,,只要是能被2整除且不等于2的欧拉数都是合数,,然后回头瞟一眼欧拉函数前几十项,,,除了前几项全是偶数且不等于2..............

代码如下:

#include<stdio.h>
int main()
{
    int t,a;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%d",&a);
    	if(a==1) printf("5\n");
    	else printf("%d\n",a+5);
	}
	return 0;
}
​​

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值