HDU-2824 The Euler function

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
InputThere are several test cases. Each line has two integers a, b (2<a<b<3000000).OutputOutput the result of (a)+ (a+1)+....+ (b)Sample Input
3 100
Sample Output
3042

// 线性筛法求欧拉函数

#include <cstdio>

#define MAX 3000001

typedef long long LL;

LL phi[MAX];

void euler() {
    for( LL i = 1; i < MAX; i++ )  phi[i] = i;
    for( LL i = 2; i < MAX; i++ ) {
        if( phi[i] == i ) {   //如果i是质数
            for( LL j = i; j < MAX; j += i ) {
                phi[j] = phi[j] / i * ( i - 1 );    //提一个1/i,先进行除法是为了防止中间数据的溢出
            }
        }
    }
}

int main() {
    euler();
    LL a, b;
    while( scanf( "%lld%lld", &a, &b ) != EOF ) {
        LL sum = 0;
        for( LL i = a; i <= b; i++ ) sum = sum + phi[i];
        printf( "%lld\n", sum );
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值