HDOJ-2199 Can you solve this equation?

7 篇文章 0 订阅
                     Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16473 Accepted Submission(s): 7301

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 = Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
2
100
-4

Sample Output
1.6152
No solution!

这个题运用二分很好算,当然要注意函数是否递增,求一阶、二阶导数即可,注意判断条件,因为是double型的,所以要用1e-12.
代码如下:

#include <algorithm>
#include <cstdio>
#include <math.h>
#include <string.h>
#define eps 1e-12
using namespace std;
double cmp(double x){
    return 8*pow(x,4.0)+7*pow(x,3.0)+2*pow(x,2.0)+3*x+6;
}
int main(){
    int n;
    double y,z=8*pow(100.0,4.0)+7*pow(100.0,3.0)+2*pow(100.0,2.0)+306.0;
    scanf("%d",&n);
    while(n--){
        scanf("%lf",&y);
        double l=0,r=100;
        if(y-6<eps||y>z){
            printf("No solution!\n");
            continue;
        }
        else{
            int size=100;
            while(size--){
                double mid=(l+r)/2.0;
                if(y>cmp(mid))
                    l=mid;
                else
                    r=mid;
            }
        }
        printf("%.4lf\n",l);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值