Blue Jeans

题目描述:

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine ©. A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

输入:

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

输出:

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string “no significant commonalities” instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

样例输入:

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

样例输出:

no significant commonalities
AGATAC
CATCATCAT

code:

要求你找到多个字符串里的相同的最长子串,如果有一样长的,输出字典序最小的哪一个
数据量比较小,放心暴力
当时看了很多博客,绕着绕着就晕了,所幸,也不是什么特别高深的算法题
暴力实现就好

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
char a[20][500];
char b[500];
int nextt[500];
vector<string> feng;
void init()
{
	int i=0,j=-1;
	nextt[0]=-1;
	int m=strlen(b);
	while(i<m)
	{
		if(j==-1||b[i]==b[j])
		{
			i++;
			j++;
			nextt[i]=j;
		}
		else
		{
			j=nextt[j];
		}
	}
}
bool kmp(int what)
{
	int i=0,j=0;
	int flag=0;
	init();
	int n=strlen(a[what]);
	int m=strlen(b);
	while(i<n)
	{
		if(j==-1||a[what][i]==b[j])
		{
			j++;
			i++;
		}
		else j=nextt[j];
		if(j==m)
		{
			return true;
		}
	}
	return false;
}
bool cmp(string a,string b)
{
	return a<b;
}
int main()
{
	int ttt,n;
	scanf("%d",&ttt);
	while(ttt--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%s",a[i]);
		}
		int m=strlen(a[0]);
		int flag=0;
		int much;
		int sum=0;
		for(int i=0;i<m-1;i++)
		{//i表示的是从a[0]数组中,砍掉几个字符
			for(int j=0;j<=i;j++)
			{//前面砍掉几个
				int start=j,over=m-i+j-1;//后面砍掉几个
				memset(b,'\0',sizeof(b));
				int qq=0;
				for(int k=start;k<=over;k++)
				{
					b[qq++]=a[0][k];
				}//将a[0]作为子串的来源
				int jie=1;
				for(int k=1;k<n;k++)
				{
					if(!kmp(k))
					{
						jie=0;
					}
				}//匹配
				if(jie==1)
				{
					flag=1;
					feng.push_back(b);
				}
			}
			if(flag)break;
		}
		if(strlen(b)<3)printf("no significant commonalities\n",b);
		else 
		{
			sort(feng.begin(),feng.end(),cmp);
			cout<<feng[0]<<endl;//求字典序最小的那个
		}
		feng.clear();
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值