Prime Ring Problem

题目描述:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
在这里插入图片描述

输入:

n (0 < n < 20).

输出:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

样例输入:

6
8

样例输出:

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

应该算是较为基础的一个搜索题目,比较麻烦的是各种格式要求,什么换行啦,最后一个数字不能有空格啦
实现起来也算是比较容易
代码如下:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
int n;
int su[50];
int a[50];
int feng[50];
int id=1;
void dfs(int where)
{
	if(where==n)
	{
		for(int i=0;i<n;i++)
		{
			if(i!=0)printf(" ");
			printf("%d",feng[i]);
		}
		printf("\n");
		return ;
	}
	else
	{
		for(int i=1;i<=n;i++)
		{
			if(a[i]==0&&su[i+feng[where-1]]==1)
			{
				if(where==n-1)
				{
					if(su[i+1]==1)
					{
						a[i]=1;
						feng[where]=i;
						dfs(where+1);
						feng[where]=0; 
						a[i]=0;
					}
				}
				else
				{
					a[i]=1;
					feng[where]=i;
					dfs(where+1);
					feng[where]=0; 
					a[i]=0;
				}
			}
		}
	}
}
int main()
{
	int i,j;
	for(i=0;i<=50;i++)
	{
		su[i]=1;
	}
	su[0]=su[1]=0;
	for(i=2;i<=50;i++)
	{
		if(su[i])
		{
			for(j=2*i;j<=50;j+=i)
			{
				su[j]=0;
			}
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		memset(feng,0,sizeof(feng));
		memset(a,0,sizeof(a));
		feng[0]=1;
		a[1]=1;
		printf("Case %d:\n",id);
		id++;
		dfs(1);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值