Wireless Network

题目描述:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

输入:

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

输出:

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

样例输入:

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

样例输出:

FAIL
SUCCESS

在这里插入图片描述
大体上就是说要完成连接,先给出n个电脑的位置,然后O+数字,表示激活该数字的电脑,S询问这两个电脑能否完成连接
注意,在超过某个距离之后是不可以连接成功的

一个并查集问题,与模板不同的地方也就是超过一定范围连接不了,算是并查集的应用问题吧

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int father[1005];
int n,m;
struct node{
	int x,y;
	bool have;
}feng[1005];
double juli(int x1,int y1,int x2,int y2)
{
	double ju=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
	return ju;
}
void init(int x)
{
	for(int i=1;i<=x;i++)
	{
		father[i]=i;
	}
}
int findd(int a)
{
	if(father[a]==a)return a;
	else return father[a]=findd(father[a]);
}
void unit(int a)
{
	int one=findd(a);
	for(int i=1;i<=n;i++)
	{
		if(feng[i].have&&juli(feng[i].x,feng[i].y,feng[a].x,feng[a].y)<=m)
		{
			int yy=findd(i);
			father[yy]=one;
		}
	}
}
int main()
{
	int xx,yy;
	while(~scanf("%d%d",&n,&m))
	{
		init(n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&feng[i].x,&feng[i].y);
			feng[i].have=false;
		}
		string bb;
		while(cin>>bb)
		{
			if(bb=="O")
			{
				int a;
				scanf("%d",&a);
				feng[a].have=true;
				unit(a);
			}
			else
			{
				int a,b;
				scanf("%d%d",&a,&b);
				if(findd(a)==findd(b))
				{
					printf("SUCCESS\n");
				}
				else
				{
					printf("FAIL\n");
				}
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值