ACboy needs your help again!

题目描述:

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor ?.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

输入:

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

输出:

For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

样例输入:

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

样例输出:

1
2
2
1
1
2
None
2
3

很基础的栈与队列的应用
上代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<stack>
#include<string.h>
#include<queue>
using namespace std;
int main()
{
	int ttt;
	scanf("%d",&ttt);
	while(ttt--)
	{
		string a;
		int n;
		scanf("%d",&n);
		cin>>a;
		if(a=="FIFO")
		{
			queue<int> que;
			string b;
			for(int i=0;i<n;i++)
			{
				cin>>b;
				if(b=="IN")
				{
					int m;
					scanf("%d",&m);
					que.push(m);
				}
				else
				{
					if(que.empty())
					{
						printf("None\n");
					}
					else
					{
						printf("%d\n",que.front());
						que.pop();
					}
				}
			}
		}
		else
		{
			stack<int> sta;
			string b;
			for(int i=0;i<n;i++)
			{
				cin>>b;
				if(b=="IN")
				{
					int m;
					scanf("%d",&m);
					sta.push(m);
				}
				else
				{
					if(sta.empty())
					{
						printf("None\n");
					}
					else
					{
						printf("%d\n",sta.top());
						sta.pop();
					}
				}
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值