Binary Tree Traversals

题目描述:

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
在这里插入图片描述

输入:

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

输出:

For each test case print a single line specifying the corresponding postorder sequence.

样例输入:

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

样例输出:

7 4 2 8 9 5 6 3 1

说起二叉树,但是本蒟蒻实在是看不懂大佬们的指针,看了半天才发现可以用递归
先记一下

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<stack>
#include<string.h>
#include<queue>
using namespace std;
int n;
int a[2000];
int b[2000];
void findd(int start,int over,int mid)
{
	int i;
	if(start>over)return ;
	for(i=0;i<n;i++)
	{
		if(a[mid]==b[i])
		{
			break;
		}
	}
	findd(start,i-1,mid+1);
	findd(i+1,over,mid-start+i+1);
	if(mid==0)printf("%d\n",a[mid]);
	else printf("%d ",a[mid]);
}
int main()
{
	while(~scanf("%d",&n))
	{
		int i;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&b[i]);
		}
		findd(0,n-1,0);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值