Tree Recovery

题目描述:

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                           D

                                          / \

                                         /   \

                                        B     E

                                       / \     \

                                      /   \     \

                                     A     C     G

                                                /

                                               /

                                              F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

输入:

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

输出:

For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).

样例输入:

DBACEGF ABCDEFG
BCAD CBAD

样例输出:

ACBFGED
CDAB

也是一道给出前序遍历和中序遍历,要求写出后序遍历的二叉树
这里就不在多说了
上代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
string a,b; 
void findd(int start,int over,int mid)
{
	if(over<start)return ;
	int i;
	for(i=start;i<=over;i++)
	{
		if(b[i]==a[mid])
		{
			break;
		}
	}
	findd(start,i-1,mid+1);
	findd(i+1,over,mid-start+i+1);
	printf("%c",a[mid]);
	if(mid==0)printf("\n");
}
int main()
{
	while(cin>>a>>b)
	{
		findd(0,a.length()-1,0);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值