Frogger

题目描述:

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

输入:

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

输出:

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

样例输入:

2
0 0
3 4

3
17 4
19 4
18 5

0

样例输出:

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

看到这一题,,,,居然第一时间想到了。。。二分。。。
当然,实际上这个是最短路径的变形啦

题目大意:

求青蛙能够到达目的地,最小的跳跃范围(在跳跃范围内的可以随便跳)。

每次就是选取他从现在跳跃点,到下一点的跳跃的最小一步,取所有最小步中的最大值就是答案了。

code:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
const int inf=99999999;
double a[2005][2005];
int visit[2005];
double d[2005];
int n;
int x[205];
int y[205];
double distancee(int a,int b,int x,int y)
{
	return sqrt((a-x)*(a-x)+(b-y)*(b-y));
}
void djstera(int start)
{
	fill(d,d+n,inf);
	memset(visit,0,sizeof(visit));
	d[start]=0.0;
	while(1)
	{
		int v=-1;
		for(int i=0;i<n;i++)
		{
			if(!visit[i]&&(v==-1||d[i]<d[v]))
				v=i;
		}
		if(v==-1)break;
		visit[v]=1;
		for(int i=0;i<n;i++)
		{
			d[i]=min(d[i],max(d[v],a[v][i]));//注意这里,求每一次跳跃的最小值
		}
	}
}
int main()
{
	int tt=1;
	while(~scanf("%d",&n))
	{
		if(n==0)break;
		memset(a,0,sizeof(a));
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(i!=j)
				a[i][j]=inf;
			}
		}
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);
		}
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				a[i][j]=a[j][i]=distancee(x[i],y[i],x[j],y[j]);//求每两块石头的距离
			}
		}
		djstera(0);
		printf("Scenario #%d\nFrog Distance = %.3f\n\n",tt,d[1]);//还是想要吐槽一下,poj简直有毒%lf过不了%f倒是可以了、
		tt++;
	}
	return 0;
}

当然仔细想了想,二分一个也可以写,就是应该没有这个更快

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值