Silver Cow Party

题目描述:

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

输入:

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

输出:

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

样例输入:

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

样例输出:

10

提示:

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题目大意:

有N个农厂,其中标号为x的农场要举行party,其余农场的牛要去参加,但是牛都很懒,所以不管是过去还是回来,牛都会走对于他们自己而言最短的路,要你求出所有牛中走得时间最长的一个。

思路;Dijkstra()算法变形,也可以用SPFA算法(不过这个暂时还不怎么理解),先求出到x农场的最短距离,再转置矩阵,然后求出回去的最短距离,因为这里的路是单向的 所以得求两次。最后输出最长的一个。

code:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=99999999;
int a[2005][2005];
int cost[2005][2005];
int visit[2005];
int d[2005];
int need[2005];
int n,m,xx;
void djstera(int start)
{
	fill(d,d+n,inf);
	memset(visit,0,sizeof(visit));
	d[start]=0;
	while(1)
	{
		int v=-1;
		for(int i=0;i<n;i++)
		{
			if(!visit[i]&&(v==-1||d[i]<d[v]))
				v=i;
		}
		if(v==-1)break;
		visit[v]=1;
		for(int i=0;i<n;i++)
		{
			d[i]=min(d[i],d[v]+a[v][i]);
		}
	}
}
int main()
{
	while(~scanf("%d%d%d",&n,&m,&xx))
	{
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(i!=j)
				{
					a[i][j]=inf;
					cost[i][j]=inf;
				}
				else
				{
					a[i][j]=0;
					cost[i][j]=0;
				}
			}
		}
		int i,j;
		int x,y,dis;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&x,&y,&dis);
			if(a[x-1][y-1]>dis)
			{
				a[x-1][y-1]=dis;
			}
		}
		djstera(xx-1);
		for(i=0;i<n;i++)
		{
			need[i]=d[i];
		}
		//因为是单向的路径,为了使起点确定,将二者翻转,也算是一个本题的一个小技巧
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)//注意这里,不要从j=0开始,当初写的时候感觉自己写的没有毛病,然而就是过不了,后来发现翻转了两次
			{
				swap(a[i][j],a[j][i]);
			}
		}
		djstera(xx-1);
		int ans=0;
		int what;
		for(i=0;i<n;i++)
		{
			if(d[i]+need[i]>ans)
			{
				ans=d[i]+need[i];
				what=i;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值