hdu1220 Cube

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2278    Accepted Submission(s): 1832


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
0 16 297
Hint
Hint
The results will not exceed int type.

题目意思:给你一个n阶立方体,大立方体可以继续分成1*1*1的小立方体,小立方体之间会有一些公共顶点,问公共点小于
等于两个的顶点的立方体对数


解题思路:
首先确定,公共顶点可能的情况:
1、存在0个公共顶点,两个立方体之间无任何交集
2、存在1个公共顶点,其中一个立方体在与另外一个立方体的相邻立方体非同行或同列相邻
3、存在2个公共顶点,两个立方体共用一条边
4、三个公共顶点不存在的,三个顶点就是共用一个三角形,不肯能存在。
5、存在四个顶点,两个立方体共用一个面
6、其他的都不可能出现


我们可以先计算出所有种数,再减去四个公共顶点的情况就是最后情况了
所有种数情况:C(n*n*n,2)=n*n*n*(n*n*n-1)/2;


接下来讨论四个公共顶点的情况
第一种思路:
除去大立方体表面的面其他的都可以共面,我们可以直接用大立方体的总面数减去表面的面数,6*n*n*n-6*n*n;但要记得去重除以2,两个立方体组成一组。
第二种思路:
每一列都可以有n-1组,从一个面往后看有n*n列,从前后两个面看是同一种情况,从左右面看是一种情况,从上下面看是一种情况。所以再乘上3。


#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%lld\n",(long long)(n*n*n*(n*n*n-1)/2)-3*n*n*(n-1));
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值