HDU 2955 Robberies(0-1背包问题)

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

这里写图片描述

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4
6

注意:这里的n说是小于100但是吧 我开1000都错了 改成1e5+10就A了
在这里寻常思路会把概率做为背包总值来计算 但是因为概率是浮点数所以并不能直接使用0-1背包 需要每项乘10^n来转换为浮点数,较麻烦
所以选择使用银行钱数作为背包总值,将概率作为价值,求不被抓时的最大的背包容量 被抓概率为p 则不被抓概率就为1-p

所以得出状态转移方程:dp[j]=maxx(dp[j],dp[j-m[i]]*(1-p[i]))

代码:

//0-1背包问题

//一个强盗想去b个银行进行偷到,已知每个银行最多可以被偷的钱数和被抓的概率,还知道他所能忍受的最大被抓概率
//问在可容忍的概率下最多可以偷多少钱
//在这里因为概率是浮点数 所以不好操作 故把钱数做背包容量,概率做价值求不被抓时最大的背包容量
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>

using namespace std;
const int N=1e5+10;
double p[N],dp[N];
int m[N];

double maxx(double aa,double bb)
{
    if(aa>bb) return aa;
    else return bb;
}

int main()
{
    ios::sync_with_stdio(false);
    int T;
    cin>>T;
    while(T--)
    {
        double a;
        int b;
        cin>>a>>b;
        memset(dp,0,sizeof(dp));
        int sum=0;
        for(int i=0; i<b; i++)
            cin>>m[i]>>p[i],sum+=m[i];
        dp[0]=1;
        for(int i=0; i<b; i++)
        {
            for(int j=sum; j>=m[i]; j--)
                dp[j]=maxx(dp[j],dp[j-m[i]]*(1-p[i]));
        }
        for(int i=sum; i>=0; i--)
        {
            if(dp[i]>(1-a))
            {
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值