POJ 1118 Lining Up【几何】

Lining Up
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

"How am I ever going to solve this problem?" said the pilot. 

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 


Your program has to be efficient! 

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3
 
    
 
    
 
    
 
    
       ①证明三点共线:利用交叉相乘差为零,本题公式:(x[a]-x[c])*(y[c]-y[b])=(x[c]-x[b])*(y[a]-y[c])(a,b,c代表三个点)
                                   注意:向量的方向性。
                 
         ②两点确定一条直线,先确定两个点所在直线再去找在这个直线上的其他点。
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF=0x7ffffff;

const int M=700;
int x[M],y[M];
int i,j,k,n,m;
int ans,cnt;

int f(int a,int b,int c)
{
    int cnt=0;
    for(int i=c+1;i<n;i++){
        if(b*(x[c]-x[i])==a*(y[c]-y[i]))cnt++;
    }
    return cnt;
}

int solve()
{
    int Max=1;
    for(int i=0;i<n;i++)
      for(int j=i+1;j<n;j++){
        int u=f(x[i]-x[j],y[i]-y[j],j)+2;
        Max=max(Max,u);
      }
      return Max;
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        rep(i,0,n)scanf("%d%d",&x[i],&y[i]);
        printf("%d\n",solve());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值