POJ 3258 River Hopscotch【二分:最大化最小值】



Language:
River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13769 Accepted: 5855

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4


就相当于把(n-k+1)块石头放入给出的位置,求最大化最小值

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<string>  
#include<cmath>  
#include<queue>  
#include<stack>  
#include<vector>  
#include<map>  
#include<algorithm>  
using namespace std;  
#define ll long long  
#define ms(a,b)  memset(a,b,sizeof(a))  
const int M=1e5+10;  
const int inf=0x3f3f3f3f;  
const int mod=1e9+7; 
int i,j,k,n,m; 
int a[M]; 
int b[M];
double y[M];

bool check(int mid)
{
	int last=0;
	for(int i=0;i<n-k+1;i++){
		int cur=last+1;
	 while(cur<=n+1&&a[cur]-a[last]<mid)cur++;
	 if(cur>n+1)return false;
	 last=cur;
	}
	return true;
}
int main()
{
	int L;
	while(~scanf("%d%d%d",&L,&n,&k)){
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[0]=0,a[n+1]=L;
		sort(a,a+n+1);
		int lb=0,ub=L+10;
		while(ub-lb>1){
			int mid=(lb+ub)/2;
			if(check(mid))lb=mid;
			else ub=mid;
		}
		printf("%d\n",lb);
	}
	return 0;
}


Language:
River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13769 Accepted: 5855

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值