After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input
- Lines 1…: Same input format as “Navigation Nightmare”.
Output - Line 1: An integer giving the distance between the farthest pair of farms.
Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
Sample Output
52
Hint
The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.
树的直径问题
#include<iostream>
#include<cstdio>
#include<sstream>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#include<map>
#include<set>
#include<fstream>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
#define maxn 100005
int from[maxn],to[maxn],w[maxn],next[maxn],dis[maxn];
int p,n,m,maxd,cnt;
void dfs(int u,int father)
{
for(int i=from[u];i;i=next[i])
{
if(to[i]==father) continue;
else
{
dis[to[i]]=dis[u]+w[i];
if(maxd<dis[to[i]])
{
maxd=dis[to[i]];
p=to[i];
}
dfs(to[i],u);
}
}
}
void add(int a,int b,int d)
{
next[cnt]=from[a];
from[a]=cnt;
to[cnt]=b;
w[cnt]=d;
cnt++;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
cnt=1;
memset(next,0,sizeof(next));
memset(from,0,sizeof(from));
memset(to,0,sizeof(to));
int a,b,d;
char ch;
for(int i=1;i<=m;i++)
{
scanf("%d%d%d %c",&a,&b,&d,&ch);
add(a,b,d);
add(b,a,d);
}
maxd=0;
dis[1]=0;
dfs(1,0);
dis[p]=0;
dfs(p,0);
printf("%d\n",maxd);
}
return 0;
}