Cow Marathon POJ - 1985(树的直径模板题)

Cow Marathon POJ - 1985

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.

Input
* Lines 1…..: Same input format as “Navigation Nightmare”.
Output
* Line 1: An integer giving the distance between the farthest pair of farms.
Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint
The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.

关于树的直径的讲解和证明个人感觉讲的挺明白

code:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1e5+10;
int tot,n,m,nxt[N],dis[N],to[N],head[N],val[N],v,maxd,po;
char c;
void addedge(int u,int v,int w){
    to[++tot] = v;
    val[tot] = w;
    nxt[tot] = head[u];
    head[u] = tot;
}
void dfs(int u,int fa){
    for(int i = head[u]; i; i = nxt[i]){
        v = to[i];
        if(v != fa){
            dis[v] = dis[u] + val[i];
            if(dis[v] > maxd){
                maxd = dis[v];
                po = v;
            }
            dfs(v,u);
        }
    }
}
int main(){
    int x,y,z;
    scanf("%d%d",&n,&m);
    for(int i = 1; i <= m; i++){
        scanf("%d%d%d %c",&x,&y,&z,&c);
        addedge(x,y,z);
        addedge(y,x,z);
    }
    dis[1] = 0;
    dfs(1,0);
    dis[po] = 0;
    dfs(po,0);
    printf("%d",maxd);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值