Problem C: 4n+1型质数统计

116 篇文章 2 订阅
45 篇文章 9 订阅

Problem Description

编程求解2-N以内全部4n+1型的质数的数目。
注意:请将质数的判断写成函数。

Input Description

输入一个正整数N(N>2)。

Output Description

输出2-N以内全部4n+1型的质数的个数。

Sample Input

100

Sample Output

11

答案:

#include <stdio.h>
#include <stdbool.h>
#include <math.h>
int zhishu(int x)
{
    int y, z;
    y = sqrt(x);
    for(z = 2; z <= y; ++z)
    {
        if(x % z == 0)
            return 0;
    }

}

int main()
{
    int n, m = 0;
    scanf("%d", &n);
    for(m = 0; n > 2; n--)
    {
        if((n - 1) % 4 == 0 && zhishu(n) != 0)
            m++;
    }

    printf("%d", m);

    return 0;

}


#include <stdio.h>
#include <stdbool.h>
#include <math.h>

int zhishu(int x)
{
    int y, z;
    y = sqrt(x);
    for(z = 2; z <= y; ++z)
    {
        if(x % z == 0)
            return 0;
    }

}
int hunwen(int x)
{
    int a, b, c, d;
    a = x % 10;
    b = x / 10000;
    c = x % 100 / 10;
    d = x / 1000 % 10;
    if(a == b && c == d)
        return 0;

}

int main()
{
    int n = 10000, i;
    for(n = 10000, i = 1; n < 99999; n++)
    {
        if(zhishu(n) == 0 && hunwen(n) == 0)
            i++;

    }

    printf("%d", i);

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小木苓

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值