10300 - Ecological Premium

Ecological Premium

Time limit : 3.000 seconds

German farmers are given a premium depending on the conditions at their farmyard 【溢价取决于他们农场的条件】.Imagine the following simplified regulation .you know the size of each farmer's farmyard in square meters and the number of animals living at it .We won't make a difference between different animals ,although this is far from reality.Moreover you have information about the degree the farmer uses environment-friendly equipment and practices,expressed in a single integer greater than zero .The amount of money a farmer receives can be calculated from these parameters as follows.First you need the space a single animal occupies at an average .This value (in square meters) is then multiplied by the parameter that stands for the farmer's environment- friendiness .resulting in the premium a farner is paid per animal he owns.To compute the final premium of a farmer just multiply this premium animal with the number of animals the farmer owns.

Input

The first line of input contains a single positive integer n (n < 20),the number of test cases .Each test case starts with a line containing a singke integer f (0<f<20),the number of farmers in the test case .This line is followed by one line per farmer containing three positive integers each :the size of the farmyard in square meters ,the number of animals he owns and the integer value that expresses the farmers environment-friendliness.Input is terminated by end of file .No integer in the input is greater than 100000 or less than 0.

Output

For each test case output one line containing a single integer that holds the summed burden for Germany's budget ,which will always be a whole number .Do not output any blank lines.

Sample Input

3

5

1 1 1

2 2 2

3 3 3

2 3 4

8 9 2 

3

9 1 8

6 12 1

8 1 1

3

10 30 40

9 8 5

100 1000 70

Sample Output

38

86

7445

Code: 在UVa oj 总是显示 compilation error ,还未accepted ,先把代码贴上。

#include<iostream>
using namespace std;
#include <stdio.h>
int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		int n;
		scanf("%d", &n);
		long long sum = 0;
		while (n--) {
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			sum += a * c;
		}
		printf("%lld\n", sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

北溟南风起

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值