10055 - Hashmat the Brave Warrior

                          10055 - Hashmat the Brave Warrior

                                          Time limit : 3.000 seconds

Hashmat is a brave warrior【武士,勇士; 军人; 鼓吹战争的人; 】 who with his group of young soldiers moves from one place to another to fight against his opponents. Before Fighting he just calculates one thing, the difference between his soldier number and the opponent’s soldier number. From this difference he decides whether to fight or not. Hashmat’s soldier number is never greater than his opponent.
 

Input

The input contains two numbers in every line. These two numbers in each line denotes【代表; 指代; 预示; 意思是; 】 the number soldiers in Hashmat’s army and his opponent’s army or vice versa【反之亦然; 反过来也一样; 】. The input numbers are not greater than 2^32. Input is terminated by ‘End of File’.

Output

For each line of input, print the difference of number of soldiers between Hashmat’s army and his opponent’s army. Each output should be in seperate line.
 

Sample Input
10 12

10 14

100 200
Sample Output
2

4

100

code1:

//系 读不懂题目篇 
//第一次提交的尴尬代码 
#include<stdio.h>
#include<iostream>
using namespace std;

void outPut(long long  a,long long b)
{
	int count = 0;
	for(int i=a;i<b;i++)
	{
		count++;	
	}
	cout<<count<<endl;
}
int main()
{
	long long m,n;
	while(scanf("%lld%lld",&m,&n)!=EOF)
	{
		outPut(m,n);
	}
	return 0;
}

code2:

#include<stdio.h>
#include<iostream>
using namespace std;

int main()
{
	long long m,n;
	while(scanf("%lld%lld",&m,&n)!=EOF)
	{
		cout<<n-m;
	}
	return 0;
}

code3: accepted 

#include<stdio.h>
#include<iostream>
using namespace std;

int main()
{
	long long m,n;
	while(scanf("%lld%lld",&m,&n)!=EOF)
	{
		if (n-m>0) cout<<n-m;
        else cout<<m-n;
	}
	return 0;
}

收获不少。 

vice versa:

1. and vice versa ;

We gossip about them and vice versa. 我们在议论他们,他们也在议论我们。

and vice versa 通常跟在句子的最后,来表示「反之亦然」,and 前面的逗号可加可不加。

 

2. or vice versa ;

vice versa 还可以用来暗示「二选一」,这个时候得用 or vice versa:

Should I come to your house or vice versa? 是我去你家里,还是你来我家?

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
我理解你的问题是关于在Spring Boot 3中使用Micrometer Tracing Bridge Brave进行RabbitMQ链路追踪时遇到的问题。 首先,你需要在你的项目中添加以下依赖: ```xml <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-core</artifactId> </dependency> <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-registry-prometheus</artifactId> </dependency> <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-registry-zipkin</artifactId> </dependency> <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-tracing-bridge-brave</artifactId> </dependency> ``` 然后,在你的配置文件中,你需要启用Micrometer和Zipkin: ``` management.metrics.export.zipkin.enabled=true management.metrics.export.zipkin.uri=http://localhost:9411 ``` 接下来,你需要配置RabbitMQ,以便将跟踪信息添加到消息头中: ``` @Bean public RabbitTemplate rabbitTemplate(ConnectionFactory connectionFactory, Tracer tracer) { RabbitTemplate rabbitTemplate = new RabbitTemplate(connectionFactory); rabbitTemplate.setBeforePublishPostProcessors(message -> { Span span = tracer.currentSpan(); if (span != null) { message.getMessageProperties().setHeader("X-B3-TraceId", span.context().traceIdString()); message.getMessageProperties().setHeader("X-B3-SpanId", span.context().spanIdString()); } return message; }); return rabbitTemplate; } ``` 最后,你需要在你的应用程序中创建一个跨度: ```java @Autowired private Tracer tracer; public void sendMessage() { Span span = tracer.nextSpan().name("sendMessage").start(); try (Tracer.SpanInScope ws = tracer.withSpan(span)) { // 发送消息 } finally { span.finish(); } } ``` 如果你的链路追踪仍然无效,可能是因为你的RabbitMQ配置不正确或你的Zipkin服务器没有启动。你可以使用Zipkin UI查看跟踪信息,或者使用Zipkin API查询跟踪信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

北溟南风起

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值