Party All the Time HDU - 4355 (三分)

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

InputThe first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1]for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )OutputFor each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10

Sample Output

Case #1: 832

 

题目要求(fabs(s))^3*w的最大值,可以得出计算该值的函数,该函数为一个三次函数,但是因为有绝对值的约束,所以是一个凸性函数,而且知道区间范围,可以通过三分的方法,逼近所要求的最大值的x,然后计算该x所对应的值就可以了,最后题目要求取整,四舍五入,加上0.5取整就可以了。最后记住不能用cin和cout,否则会超时。

代码:

 

#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
const double eps = 1e-8;
const int N = 5e4 + 10;
const int M = 0x3f3f3f3f;
struct Point
{
    double x;
    double w;
}p[N];
int n;
double cal(double x)
{
    double ans = 0;
    for(int i = 0; i < n; ++ i)
    {
        double cnt = fabs(p[i].x-x);
        ans += cnt*cnt*cnt*p[i].w;
    }
    return ans;
}
double three_fen(double l, double r)
{
    while(r-l > eps)
    {
        double mid = (l+r)/2.0;
        double rmid = (mid+r)/2.0;
        double ans1 = cal(mid);
        double ans2 = cal(rmid);
        if(ans1 < ans2)
        {
            r = rmid;
        }
        else
        {
            l = mid;
        }
    }
    return l;
}
int main()
{
    int T, cas = 0;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        double minn = M;
        double maxn = -M;
        for(int i = 0; i < n; ++ i)
        {
            scanf("%lf%lf", &p[i].x, &p[i].w);
            minn = min(minn, p[i].x);
            maxn = max(maxn, p[i].x);
        }
        double res = three_fen(minn, maxn);
        int ans = cal(res)+0.5;
        printf("Case #%d: %d\n", ++cas, ans);
    }
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值