【POJ - 2417】Discrete Logging(BSGS)

1 篇文章 0 订阅

Given a prime P, 2 <= P < 2 31, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that 

    BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space.

Output

For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587

Hint

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states 

   B(P-1) == 1 (mod P)


for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m 

   B(-m) == B(P-1-m) (mod P) .

BSGS简介:

BSGS可以在O(C^0.5)的时间内求解出 A^x≡B(mod C)

由费马小定理可知,x可以在O(C)的时间内求解,在x=c之后又会循环;

 

思路:

Baby Step Giant Step大步小步算法,这是一道裸的模板题,但是我用mapTLE多次后终于过了,吸取教训能累乘的地方千万不要用快速幂。。。

自己用map的程序(耗时4782ms)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
map<ll,int> mp;//ll->int
ll qsm(ll a,ll b,ll p)
{
	ll t=1;
	while(b>0)
	{
		if(b&1)	t=(t*a)%p;
		a=(a*a)%p;
		b>>=1;
	}
	return t;
}
ll BSGS(ll a,ll b,ll p)
{
	mp.clear();
	b%=p;
	ll t=ceil(sqrt(p));
	ll val=b%p;//i=0时 
	for(int i=0;i<=t;i++)
	{
		mp[val]=i;
		val=(val*a)%p;
	}
	a=qsm(a,t,p);//a^t
	if(a==0) return b==0?1:-1;
	val=a;
	for(int i=1;i<=t;i++)
	{
		if(mp[val])
		{
			int ans=i*t-mp[val];
			return (ans%p+p)%p;
		}
		val=(val*a)%p;
	}
	return -1;
} 
int main()
{
	ll a,b,p;
	while(~scanf("%lld%lld%lld",&p,&a,&b))
	{
		ll ans=BSGS(a,b,p);
		if(ans==-1)
			puts("no solution");
		else
			printf("%lld\n",ans);
	}
	
	return 0;
 } 

kuangbin大佬的模板,耗时47ms:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
//baby_step giant_step
// a^x = b (mod n) n为素数,a,b < n
// 求解上式 0<=x < n的解
#define MOD 76543
int hs[MOD],head[MOD],next[MOD],id[MOD],top;
void insert(int x,int y)
{
    int k = x%MOD;
    hs[top] = x, id[top] = y, next[top] = head[k], head[k] = top++;
}
int find(int x)
{
    int k = x%MOD;
    for(int i = head[k]; i != -1; i = next[i])
        if(hs[i] == x)
            return id[i];
    return -1;
}
int BSGS(int a,int b,int n)
{
    memset(head,-1,sizeof(head));
    top = 1;
    if(b == 1)return 0;
    int m = sqrt(n*1.0), j;
    long long x = 1, p = 1;
    for(int i = 0; i < m; ++i, p = p*a%n)insert(p*b%n,i);
    for(long long i = m; ;i += m)
    {
        if( (j = find(x = x*p%n)) != -1 )return i-j;
        if(i > n)break;
    }
    return -1;
}
int main()
{
	int a,b,p;
	while(~scanf("%d%d%d",&p,&a,&b))
	{
		int ans=BSGS(a,b,p);
		if(ans==-1)
			puts("no solution");
		else
			printf("%d\n",ans);
	}
	
	return 0;
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值