【HDU - 1028】Ignatius and the Princess III(生成函数)

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 

Sample Input

4
10
20

Sample Output

5
42
627

思路:

生成函数模板题。学习博客

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef  long long ll;
const ll MAX=220000;
ll a[MAX],b[MAX];
int main() {
	int n;
	while(cin>>n)
	{
		for(int i=0;i<=n;i++)//首先对a初始化,由第一个表达式(1+x+x^2+..x^n)初始化。
		{
			a[i]=1;
			b[i]=0;
	    }
                //这道题中说的是由1~n中的所有的数选一些凑出目标值,能写成n个表达式的乘积,所需下面的循环是要小于等于n的。
		for(int i=2;i<=n;i++)//从第二个表达式开始,处理每一个表达式
		{
			for(int j=0;j<=n;j++)//对于指数为j的进行操作,这里操作的是之前累乘完后的表达式的每一项
			{
				for(int k=0;j+k<=n;k+=i)//k表示的是表达式中的指数,所以k每次增i(因为第i个表达式的增量是i)
				{
					b[j+k]+=a[j];
				}
			}
			for(int j=0;j<=n;j++)//b是中间数组,把中间值赋值到最终结果的数组中,并重新赋值为0
			{
				a[j]=b[j];
				b[j]=0;	
			}
		}
		cout<<a[n]<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值