B - Ignatius and the Princess III 整数拆分问题

B - Ignatius and the Princess III
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 

Sample Input

4
10
20

Sample Output

5
42

627

母函数的应用之一整数拆分问题,不过要注意本题n=n也是一种情况

在这里说一下整数拆分问题举题目中的例子f(x)=(1+x+x^2+x^3+x^4)*(1+x^2+x^4)*(1+x^3)*(1+x^4)

讲4拆分后的答案其实就是f(X)展开式中x^4的系数,对此有两种理解

1.讲4拆分拆分的数中与1有关的有1,2,3,4 与2有关的为2,4 与3有关的3 与4有关的4

2.也可以理解为有无限个1,2,3,4问组成4的方案数,这就转化为与母函数的定义中的例子一样了

ac代码;

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int c1[1000], c2[1000];
int val[1000];
int main()
{
    int n,i, j, k;
    while(cin>>n)
    {
        for(i = 1; i <=n; i++)
        {
            val[i]=i;
        }
        memset(c1, 0, sizeof(c1));
        memset(c2, 0, sizeof(c2));
        for(i = 0; i <=n; ++i)
        {
            c1[i]=1;
        }
        for(i = 2; i <=n; i++)
        {
            for(j = 0; j <=n; j++)
            {
                for(k = 0; j+ k<=n; k+=val[i])
                {
                    c2[j + k] += c1[j];
                }
            }
            for(j = 0; j <=n; ++j)
            {
                c1[j] = c2[j];
                c2[j] = 0;
            }
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值