【HDU - 6300】Triangle Partition (思维+不相交的三角形)

11 篇文章 0 订阅

Chiaki has 3n3n points p1,p2,…,p3np1,p2,…,p3n. It is guaranteed that no three points are collinear. 
Chiaki would like to construct nn disjoint triangles where each vertex comes from the 3n3n points. 

Input

There are multiple test cases. The first line of input contains an integer TT, indicating the number of test cases. For each test case: 
The first line contains an integer nn (1≤n≤10001≤n≤1000) -- the number of triangle to construct. 
Each of the next 3n3n lines contains two integers xixi and yiyi (−109≤xi,yi≤109−109≤xi,yi≤109). 
It is guaranteed that the sum of all nn does not exceed 1000010000. 

Output

For each test case, output nn lines contain three integers ai,bi,ciai,bi,ci (1≤ai,bi,ci≤3n1≤ai,bi,ci≤3n) each denoting the indices of points the ii-th triangle use. If there are multiple solutions, you can output any of them. 

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3

思路:

对x轴排序,依次3个一组的选,直到选完,这样选得的三角形不会相交(题目中保证没有三个点共线),比如:第4个点有两种可能,一是和第3个点横坐标相同,另一个是在第3个点的后面,第二种情况,选也是往后选,不可能和前面的三角形相交,第一种情况,因为已经两个点横坐标相同了,所以说下一个点一定在这个点的后面,那么和后面的一个点相连,一定不会和第3个点相交(两点确定一条直线)。

注意细节,题目给出一个n,但实际给出3*n个点,所以在读入、输出、排序时填的参数都是3*n。

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
struct node{
	ll x,y;
	int id;
	void input(int i)
	{
		id=i;
		scanf("%lld%lld",&x,&y);
	}
	friend bool operator<(node a,node b)
	{
		return a.x<b.x;
	} 
}po[10000]; 
int main()
{
//	freopen("out.txt","w",stdout);
	int t;
	cin>>t;
	while(t--)
	{
		int n,x,y;
		scanf("%d",&n);
		for(int i=1;i<=3*n;i++)//3*n个点,注意数组大小 
		{
			po[i].input(i); 
		} 
		sort(po+1,po+3*n+1);//注意是3*n 
		for(int i=1;i<=3*n;i+=3)
		printf("%d %d %d\n",po[i].id,po[i+1].id,po[i+2].id);
		
	} 
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值