【HDU - 1005】Number Sequence (矩阵快速幂)

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n). 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 

Output

For each test case, print the value of f(n) on a single line. 

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

思路:

第一眼感觉跟斐波那契很像,然后又发现n很大,然后推了公式,写了矩阵快速幂。

递推公式:

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
#define mod (1000000007)
using namespace std;
typedef long long ll;
//矩阵快速幂,求公式 
struct node{
	int m[4][4];
	void init()
	{
		memset(m,0,sizeof(m)); 
	}
	void one()
	{
		m[0][0]=1;
		m[1][1]=1;
		m[2][2]=1;
	} 
};
node mul(node a,node b)
{
	node t;
	t.init();t.one();
	for(int i=0;i<=2;i++)
	{
		for(int j=0;j<=2;j++)
		{
			int sum=0;
			for(int k=0;k<=2;k++)
			{
				sum+=a.m[i][k]*b.m[k][j];
			}
			t.m[i][j]=sum%7;
		} 
	}
	return t;
}
node qsm(node a,int b)
{
	node t;
	t.init();t.one();
	while(b)
	{
		if(b&1)
		{
			t=mul(t,a);
		}
		a=mul(a,a);
		b>>=1;
	}
	return t;
}
int main()
{
	int A,B,n;
	while(~scanf("%d%d%d",&A,&B,&n),A+B+n)
	{
		if(n==1||n==2)
		{
			printf("1\n");continue;
		}
		else if(n==3)
		{
			printf("%d\n",(A+B)%7); continue;
		}
		node f;
		f.init();
		f.m[0][0]=A;f.m[0][1]=B;
		f.m[1][0]=1;f.m[2][1]=1;
		node ans=qsm(f,n-3);
		int ot=(ans.m[0][0]*(A+B)+ans.m[0][1]+ans.m[0][2])%7;
		printf("%d\n",ot);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值