PTA Maximum Subsequence Sum

题目

Given a sequence of K integers { N 1 ​ , N 2 ​ , . . . , N K ​ N_1​, N_2​, ..., N_K​ N1,N2,...,NK }. A continuous subsequence is defined to be { N i ​ , N i + 1 ​ , . . . , N j N_i​, N_{i+1}​, ..., N_j Ni,Ni+1,...,Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

题目大意

求解一段序列的最大子列和,并输出最大值时的第一个数字与最后一个数字。

输入

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

输出

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i i i and j j j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

样例输入

10
-10 1 2 3 4 -5 -23 3 7 -21

样例输出

10 1 4

题目分析

此题主要在于没有仔细看输出要求,导致错了好几次。
首先,若是一段含有正数的复杂数据可按照一般情况运算,不断找出整治,更新max.
然后,若是全为负,则需要输出序列第一个和最后一个数,并且最大值定为零。
最后,存在前数位全为零时,输出时需将零计入,同时若是最后部分全为零,则以最后一个非零数字输出。

代码

#include<iostream>
using namespace std;
int main(){
	int n,ans=0,k,max,p1,p2,ps,pe,flag = 0,flagm=0;
	//p1,p2计入临时初末位置,ps,pe计入最终初末位置
	cin >> n;
	max = 0;
	for(int i = 0;i<n;++i){
		scanf("%d",&k);
		if(i == 0){
			p1 = ps = k;
		}
		ans += k;
		p2 = k;
		if(flag){//flag用于判定是否改变最大序列的初始位
			flag = 0;
			p1 = k;
		}
		if(ans >= max){//更新max
			if(ans == 0 || ans > max){
			//前n项为零与大于max方可更新
				flagm = 1;
				max = ans;
				ps = p1;
				pe = p2;
			}
		}
		if(ans < 0){
			ans = 0;
			flag = 1;
		}

	}
	if(flagm == 0) pe = p2;//flagm判定是否全为零
	cout << max<<" "<<ps<<" "<<pe<<endl;
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

registor11

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值