POJ 3321 Apple Tree【树状数组】

题目

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.
The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.
The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?
在这里插入图片描述

题目大意

有一棵二叉树,每一个结点(包括根结点)上都有一个苹果,给定二叉树的边关系。随后有两个操作:
Q x 查询x节点及其子树上所有苹果数目。
C x 若x节点处有苹果则采摘,无苹果则生长出一个。
输出每次查询的苹果数目。

input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

分析

对于构建出来的二叉树,先行dfs搜索每一个节点,并标记每个结点的编号以及包含的编号范围。如题中所给图,判断出1号节点查询时,范围是[1,5],查询3号节点时,范围是[3,5]。这里的范围用数组L[]与R[]进行表示当前节点的左右查询范围。在查询节点 i i i上的苹果数目时,即为区间查询,可以通过sum(R[i])-sum(L[i-1])计算出苹果数目。

代码

#include<iostream>
using namespace std;
int head[100100],cnt = 1;
struct E{
	int to,next;
}edge[200100];
int pos = 1,n;
int L[100100],R[100100],sum_a[100100],a[100100];

void add(int u,int v){//链式前项星
	edge[cnt].next = head[u];
	edge[cnt].to = v;
	head[u] = cnt++;
	edge[cnt].next = head[v];
	edge[cnt].to = u;
	head[v] = cnt++;
}
void dfs(int u,int fa){//dfs to matrix
	L[u] = pos++;//编号
	for(int i = head[u];i;i = edge[i].next){
		int v = edge[i].to;
		if(v==fa) continue;
		dfs(v,u);
	}
	R[u] = pos-1;
}
int lowbit(int x){
	return (-x)&x;
}
void change(int i,int val){
	a[i]+=val;
	while(i<=n){
		sum_a[i]+=val;
		i+=lowbit(i);
	}
}
int sum(int i){
	int ans = 0;
	while(i>0){
		ans+=sum_a[i];
		i-=lowbit(i);
	}
	return ans;
}
int main(){
	scanf("%d",&n);
	int u,v,q;
	char c;
	for(int i=1;i<n;++i){
		scanf("%d %d",&u,&v);
		add(u,v);
		change(i,1);//初始化每个结点处均有一个苹果
	}
	change(n,1);
	dfs(1,1);
	scanf("%d",&q);
	for(int i = 1;i<=q;++i){
		scanf(" %c %d",&c,&u);
		if(c=='C'){
			if(a[L[u]]) change(L[u],-1);
			else change(L[u],1);
		}
		else
			printf("%d\n",sum(R[u])-sum(L[u]-1));
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

registor11

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值