Marshal's confusion

Marshal’s confusion

one day, Marshal want to show the answer : 12+32+5^2+……+ n ^2.
please tell to him.

Input
In each case, there is an odd positive integer n.

Output
Print the sum. Make sure the sum will not exceed 2^31-1

Sample Input

3

Sample Output

10
#include <stdio.h>
int main(void)
{
    long n;
    while(scanf("%ld", &n) == 1)
    {
        long sum = 0;
        for(int i = 1; i <= n; i += 2)
        {
            sum += pow(i, 2);
        }
        printf("%ld\n", sum);
    }
}

pow(a,b):a^b

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值