哈理工OJ 1196 Marshal's confusion II(数学公式题)

题目链接:http://acm.hrbust.edu.cn/index.php?m=ProblemSet&a=showProblem&problem_id=1196

Marshal’s confusion II
Time Limit: 1000 MS Memory Limit: 65536 K
Total Submit: 285(104 users) Total Accepted: 90(81 users) Rating: Special Judge: No
Description
one day, Marshal want to show the answer :Calculate S(n).
S(n)=1^3+2^3 +3^3 +……+n^3 .
Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
Output
For each case, output the last four dights of S(N) in one line.
Sample Input
1
2
Sample Output
0001
0009
Author
王勇

【思路分析】只需要知道:1^3+2^3+3^3+…..+n^3=1/4*(n^2)*((n+1)^2)这个公式,这道题就可以做了。
【AC代码】

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
using namespace std;
#define LL long long

int main()
{
    LL n;
    while(~scanf("%lld",&n))
    {
        LL re;
        if(n%2==0)
        {
            re=((n/2)*(n/2))%10000*((n+1)*(n+1))%10000;
        }
        else
        {
            re=(n*n)%10000*(((n+1)/2)*((n+1)/2))%10000;
        }
        printf("%04lld\n",re%10000);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值