Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int a[36];
int b[36];
typedef struct node {
int key;
struct node *lchild;
struct node *rchild;
}TNode;
void Create(TNode *&root, int *s1, int *s2, int n){//s1为后根序列;s2为中根序列
if(n<=0){
return;
}
root = new(TNode);
root->key = *(s1+n-1);
root->lchild = root->rchild = NULL;
int *p = s2;
while(s2 != NULL && *p != *(s1+n-1)) p++;
int m = p - s2;
Create(root->lchild, s1, s2, m);
Create(root->rchild, s1+m, s2+m+1, n-m-1);
}
void Level(TNode *root,int n){
int a = 0;
int b = 0;
TNode *Q[36];
Q[a++] = root;
int i=0;
while(a>b){
printf(++i != n? "%d ":"%d\n",Q[b]->key);
if(Q[b]->lchild != NULL) Q[a++] = Q[b]->lchild;
if(Q[b]->rchild != NULL) Q[a++] = Q[b]->rchild;
b++;
}
}
int main()
{
int n;
cin>>n;
for(int i=0; i<n; i++){
cin>>a[i];
}
for(int i=0; i<n; i++){
cin>>b[i];
}
TNode *root = NULL;
Create(root, a, b, n);
Level(root, n);
return 0;
}