1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题意:给出n个人上班打卡的时间以及离开的时间,最早的负责开门,最晚的负责锁门,输出开门的人的ID以及关门的人的ID

思路:对时间进行转换,将时间变成秒数,则秒数越小时间越早,通过排序即可解决

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <cctype>
#include <cstring>
#include <cmath>
#include <set>
#include <sstream>

using namespace std;

struct people
{
    string name;
    int h1,m1,s1;
    int h2,m2,s2;
    int sum1,sum2;
};

vector<people>p;

bool cmp1(people a,people b)       //上班时间排序(最早优先)
{
    return a.sum1<b.sum1;
}

bool cmp2(people a,people b)         //离开时间排序(最晚优先)
{
    return a.sum2>b.sum2;
}

int main()
{
    int n;
    int h1,h2,m1,m2,s1,s2;
    string s;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        cin>>s;
        scanf("%d:%d:%d",&h1,&m1,&s1);
        scanf("%d:%d:%d",&h2,&m2,&s2);
        int temp1=h1*3600+m1*60+s1;
        int temp2=h2*3600+m2*60+s2;
        p.push_back(people{s,h1,m1,s1,h2,m2,s2,temp1,temp2});
    }
    sort(p.begin(),p.end(),cmp1);
    cout<<p[0].name<<" ";
    sort(p.begin(),p.end(),cmp2);
    cout<<p[0].name;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值